Install LibreOffice 4 with Debian Wheezy Backports

By | 2013/05/16

LibreOffice 4 is available in Debian Wheezy backports! I’ll show you how to install LibreOffice 4 on Debian Wheezy.


1. Add wheezy backports to your /etc/apt/sources.list:

deb http://ftp.debian.org/debian/ wheezy-backports main

2. Next:

$ sudo apt-get update

3. And finally install libreoffice 4.0:

$ sudo apt-get -t wheezy-backports install libreoffice

Done!

libreoffice_debian

11 thoughts on “Install LibreOffice 4 with Debian Wheezy Backports

  1. Auroch

    Thanks for this post !
    In my case, I’ve also to update libreoffice-math & python-uno from backports.

    In fact, aptitude tell me that there’s a dependencies trouble with this 2 packages and propose to let some dependencies unsatisfied … I refused and so it give me another proposal : updating these two packages from backports 😉

    Reply
  2. Chris

    Thank you for this tip, Scott.

    Not only did it give me the latest version, it also cured the terribly slow loading I had with the previous one 🙂

    Reply
  3. Len

    Thank for this very good tip Other methods didn’t work for me.

    Reply
  4. GĂ©rard Bekhuis

    Hallo.
    Thank you very much.
    I like to get the german language version.
    I have installed the english version Libreoffice 4.0
    I hope you can help me.
    Thanks and greetings
    GĂ©rard

    Reply
    1. Sylvain Nugues

      I would say you’d have to install your language package with:

      sudo apt-get -t wheezy-backports install libreoffice-l10n-xx

      xx being your language (for me it’s fr as in french).

      Reply
      1. GĂ©rard Bekhuis

        Hello Sylvain.
        I have tried “sudo apt-get -t wheezy-backports install libreoffice-l10n-de” to install.
        Then I got Libreoffice 3.0 and I will Libreoffice 4.0 in german language, because I live as Dutchman in Germany and my first ist french “GĂ©rard”.
        Perhapsyou have an other solution forme?
        Greeting GĂ©rard Bekhuis.

        Reply
  5. Fraifrai

    You should add localizations installation in your post

    Reply
  6. Hardian

    Do we need to uninstall previous version of libreoffice before install libreoffice 4?

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

Notify me of followup comments via e-mail. You can also subscribe without commenting.